PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Problem beim Compilieren


SVARTIFAR
01.05.2013, 15:09
Hallo Zusammen

Ich benutze QlandkarteGt schon laenger aus den Ubuntuquellen. Da dort allerdings nicht die aktuellste Version zu bekommen ist, und sichbei prodeia irgendwie auch nix mehr tut, habe ich mich jetzt ans Selberbauen gemacht. Dazu wird ja allgemein die Anleitung von "Schrotti" empfohlen.

Damit bin ich aber gleich beim zweiten Befehl gescheitert: Die URL zum Herunterladen schient nicht mehr aktuell. Habe folgedne Meldung erhalten:

svn co https://qlandkartegt.svn.sourceforge.net/svnroot/
svn: E175011: Unable to connect to a repository at URL 'https://qlandkartegt.svn.sourceforge.net/svnroot'
svn: E175011: Das Projektarchiv wurde zeitweilig nach »http://qlandkartegt.svn.sourceforge.net/svnroot« verschoben; bitte umplatzieren

Ich versteh das so, das das Project jetzt unter http:// liegt(statt unter https), aber auch das funktioniert nicht.

Kann mir bitte jemand sagen, wie die richtige Downloadadresse mittlerweile lautet??

Danke SVARTiFAR

kiozen
02.05.2013, 08:20
sf.net hat das Repository geändert. Am Besten immer hier nachsehen:

http://sourceforge.net/p/qlandkartegt/code/HEAD/tree/

Du kannst den Befehl mit copy-n-paste übernehmen.

SVARTIFAR
03.05.2013, 08:06
Alles klar, vielen Dank.
Wer mich dran versuchen.

SVARTIFAR

AlterSachse
10.05.2013, 18:41
HI,
habe mich gerade mal an ein Linux XUBUNTU gewagt (absoluter Neuling) und mit Hilfe eines Kollegens habe ich eine saubere QLGT install hin bekommen.
Hier mal meine Terminal Sachen hilft eventuell weiter, alles vom 05.03.13
Gruß

# originale Software deinstallieren
sudo apt-get purge qlandkartegt

# Kompilier-Tools installieren
sudo apt-get install build-essential

# Abhängigkeiten installieren
sudo apt-get install autotools-dev cmake cmake-data comerr-dev emacsen-common krb5-multidev libcurl4-gnutls-dev libdap-dev libdapserver7 libdrm-dev libgcrypt11-dev libgdal-dev libgeos-dev libgif-dev libgl1-mesa-dev libglu1-mesa-dev libgnutls-dev libgnutls-openssl27 libgnutlsxx27 libgpg-error-dev libgssrpc4 libhdf4-alt-dev libhdf5-serial-dev libidn11-dev libjasper-dev libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev libkadm5clnt-mit8 libkadm5srv-mit8 libkdb5-6 libkms1 libkrb5-dev libldap2-dev libltdl-dev libmysqlclient-dev libnetcdf-dev libp11-kit-dev libpng12-dev libpq-dev libproj-dev libpthread-stubs0 libpthread-stubs0-dev libqt4-dev libqt4-opengl-dev libqtwebkit-dev librtmp-dev libspatialite-dev libsqlite3-dev libssl-dev libssl-doc libtasn1-3-dev libtool libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev libxerces-c2-dev libxext-dev libxml2-dev libxmlrpc-core-c3 mesa-common-dev pkg-config qt4-linguist-tools qt4-qmake unixodbc-dev uuid-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev zlib1g-dev

# von Webseite http://blog.dafb-o.de/howto-ubuntu-qlandkarte-gt/ dazu genommen
sudo apt-get install lsb-cxx lsb-qt4 qt4-qmake libqt4-core

cd ~/Downloads

# Quelldateien herunterladen
wget http://netcologne.dl.sourceforge.net/project/qlandkartegt/qlandkartegt/QLandkarteGT%201.7.0/qlandkartegt-1.7.0.tar.gz

# auspacken
tar xvf qlandkartegt-1.7.0.tar.gz

cd qlandkartegt-1.7.0
mkdir build_qlandkarte
cd build_qlandkarte

# Kompiliertest
cmake ../

# kompilieren, dauer etwas
make

# als Programm installieren
sudo make install

#############################
# Garmin Treiber
# Treiber von hier holen
# http://netcologne.dl.sourceforge.net/project/qlandkartegt/garmindev/

# wechsel ins Verzeichnis
cd ~/Downloads

# Auspacken
tar xvf garmindev-0.3.4.tar.gz

sudo apt-get install libusb-0.1-4 libusb-dev
cd garmindev-0.3.4
mkdir build_garmindev
cd build_garmindev
cmake ../
make
sudo make install

####################################
# so noch was was zu qlgt gehört
sudo apt-get install gpsd

###################################
# jetzt noch was über die Softwareinstall
http://de.wikipedia.org/wiki/Benutzer:Alexrk2/SRTM-Reliefs
GDAL wird gebraucht um eine große Höhendatei zu erzeugen