PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : letzte Fehlermeldung von CMake


KKN1
27.02.2015, 15:05
Die letzte fehlermeldung bei der installation von QLGT:
p { margin-bottom: 0.1in; line-height: 120%; } CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QT_QTWEBKIT_INCLUDE_DIR (ADVANCED)
used as include directory in directory /home/klaus/Downloads/qlandkartegt-1.8.1/src


Da brauch ich Hilfe, dazu hab ich auch im Netz nichts gefunden.

kiozen
27.02.2015, 16:09
Der rot markierte Satz sagt eigentlich alles ;) .... wenn man weiß wie Distributionen ticken.

Folgendes: QT ist für viele Packetbetreuer viel zu groß. Das ist zwar, in Relation zu den Ressourcen eines heutigen Systems gesetzt, Quatsch. Aber solche Ansichten halten sich hartnäckig. Deshalb wird Qt in viele kleine Pakete zerteilt. Und wenn man etwas compilieren will, muss man zu jedem dieser Unterpakete auch das jeweilige Entwicklungspaket installieren.

In deinem Fall geht es um das Paket Qt Webkit. Schau mal in deiner Paketverwaltung nach, ob dieses Packet installiert ist und ob auch die Entwicklungskomponente (meistens mit einem "dev" markiert) installiert ist.

Wahrscheinlich kommen noch mehrere solche Meldungen. Dann muss man halt schauen, dass auch diese Pakete installiert werden.