Montana 610 - Ärger mit benutzerdefinierten Wegpunktsymbolen

  • Moin,

    seit einiger Zeit doktore ich daran herum, in meinem Montana 610 die benutzerdefinierten Wegpunktsymbole vom Montana 600 für die übertragenen Wegpunkte (=Fundplatzkoordinaten von Bodenfunden) weiterzunutzen.


    Die Verwendung der bisherigen Syntax "Custom 0.bmp" für die Dateinamen im Ordner CustomSymbols führt rigoros dazu, dass sich das neue Montana beim Starten beim Laden der Wegpunkte aufhängt und man das Gerät nur mit gutem Zureden überhaupt wieder in den Massenspeichermodus bekommt, um diese Dateien wieder zu löschen.


    Nutze ich die nummerischen Namen, also 000.bmp wie in Basecamp, lädt das System zwar und lässt mich die benutzerdefinierten Symbole auch neu zuordnen, aber alle originalen Symbole haben sich natürlich wegen des nicht mehr stimmigen Namens zu blauen Fahnen umgewandelt.

    Zudem ist das Symbol mit dem Dateinamen 009.bmp in der Liste des Garmin mit den benutzerdefinierten Wegpunktsymbolen dann plötzlich das erste (falls ich mit 001.bmp statt 000.bmp starte und daraus dann die 010.bmp wird, dann bleibt es dennoch vorn in der Liste).


    Was läuft da verkehrt?


    Ob ich die <sym>-Attribute in der waypoints.gpx irgendwie umbenennen kann, um wieder eine Übereinstimmung zwischen BaseCamp und dem Gerät zu bekommen, ist auch noch ein Test für einen anderen Tag, es sei denn, jemand hat hier einen schlauen Tipp für mich.


    Viele Grüße

    Olaf

  • Ob ich die <sym>-Attribute in der waypoints.gpx irgendwie umbenennen kann, um wieder eine Übereinstimmung zwischen BaseCamp und dem Gerät zu bekommen, ist auch noch ein Test für einen anderen Tag, es sei denn, jemand hat hier einen schlauen Tipp für mich.

    Jeder vernünftige Texteditor kann das. Mein Favorit ist hier der kostenlose NOTEPAD++

    GPX ist eine Texdatei, darin dann mit suchen/ersetzen die Textstellen verarbeiten und fertig 8)

    NOTEPAD++ kann das auch über mehrere Dateien hinweg :)

    Gruß Andi :)
    - ZÛMO 595 - FW üblicherweise aktuell - SDHC 64GB - CN NTU LifeTimeAbo
    - DriveSmart 61 - FW üblicherweise aktuell - SDHC 4GB - CN NTU LifeTimeAbo

    - Montana 680t - FW üblicherweise aktuell - SDHC 64GB - OSM-Karten
    - OREGON 450 - FW üblicherweise aktuell - SDHC 8GB - OSM-Karten

    - Mopped: R1150RT - Auto: MX5-NCFL

  • Moin,

    dass das geht, war mir schon klar, nur wie erfolglos dann wirklich, noch nicht.

    Wenn ich zugeordnete Symbole in BaseCamp manuell ändere, wird in die GPX-Datei "Custom x" beim Symol-Tag geschrieben.

    Wenn ich die Symbole im Gerät im Text durch die Namen der Symboldatei ersetze (also 000 beispielsweise), hebt das Gerät die blaue Fahne für jedes der Symbole, BaseCamp hingegen mutiert die Symbole zu schwarzen Punkten.

    Ordne ich das benutzerdefinierte Symbol direkt im Gerät zu, ebenfalls schwarze Punkte in BaseCamp.


    Ist das ein Bug, der zum Aufhängen des Gerätes beim Starten mit den alten Symboldateien führt, weil beispielsweise die Leerzeichen in den Dateinamen (Custom 0.bmp) nicht gemocht werden?

    Nun habe ich hier wegen der später gestrichenen und leider benötigten Anbindung zu Google Earth auch eine etwas ältere Version von BaseCamp am Laufen, kann es damit zusammenhängen?

    Irgendwie finde ich zu dem Thema auch nichts im Handbuch für das Montana 610/680. Wurde das Feature etwa klammheimlich gestrichen und funktioniert nur noch zufällig halbwegs?


    Danke und viele Grüße

    Olaf

    Einmal editiert, zuletzt von OlafE ()

  • Ich glaub, ich bin einen Schritt weiter. "Custom 0" ist der Eintrag, den das neuere Montana nicht mag. Ist der weg, crasht's nicht mehr, nur passen die Symbole jetzt nicht mehr.

    Irgendwas ist ja immer...


    Weiter geht's. Das Teil mit der bisherigen 000 / Custom 0 auf 010 / Custom 10 umbenannt, zusätzlich noch ein Platzhaltersymbol mit der 011 gebastelt.


    Dann in BaseCamp alle Fundplätze, die Münzen zugeordnet waren und im beobachteten Bereich für die Mehrzahl der Blue Flags/Black Dots zuständig waren, auf die 010 umgestellt.


    Nun sieht das Ganze in BaseCamp und auch im Garmin wieder weitgehend so aus, wie ich das benötige.

    Was mich noch verwirrt, ist die Reihenfolge der Symbole im Bereich Benutzerdefiniert des Garmin Montana 610:

    Aus unerfindlichen Gründen hat sich hier das Symbol Custom 9.bmp nach vorn gesetzt, gefolgt von Custom 010.bmp (was ursprünglich im Montana 600 die Custom 0.bmp war und dort auch ganz vorn aufgelistet war), alle anderen sind in der Reihenfolge korrekt. In BaseCamp wird stur die Reihenfolge der Dateinamen eingehalten (000, 001, ...)

    Gibt es da eventuell einen Cache im Gerät, den man löschen kann, damit sich die Symbolanzeige neu aufbaut?


    Viele Grüße

    Olaf

    Einmal editiert, zuletzt von OlafE ()

  • Ich glaub, ich bin einen Schritt weiter. "Custom 0" ist der Eintrag, den das neuere Montana nicht mag. Ist der weg, crasht's nicht mehr, nur passen die Symbole jetzt nicht mehr.

    Irgendwas ist ja immer...

    Nachdem "Custom 0" einen Fehler auslöst würde ich folgende Beschreibung empfehlen:


    Zitat
    • Make two copies of each 24-bit *.bmp custom symbol, one for BaseCamp, and one for the GPSr.
    • Name the BaseCamp symbols 001.bmp, 002.bmp, 003.bmp, 004.bmp, etc.
      • Only symbol names from 000.bmp - 063.bmp are recognized.
      • All BaseCamp symbol names are three digits, with leading zeros added when necessary.
    • Name the corresponding GPSr symbols Custom 1.bmp, Custom 2.bmp, Custom 3.bmp, Custom 4.bmp, etc.
      • All corresponding GPSr symbol names are prefixed with "Custom " and do not include any leading zeros.

    Quelle: https://www.gpsrchive.com/Mont…20Waypoint%20Symbols.html



    Nach der Beschreibung dürfen am Montana keine führende Nullen verwendet werden (siehe roten Text), also "Custom 010" wird offenbar auch nicht verstanden.


    Die Reihenfolge der Anzeige sollte nicht die Ursache sein, ich habe leider keine Möglichkeit das zu testen.


    Vielleicht hilft das weiter...

    Auch der längste Marsch beginnt mit dem ersten Schritt.
    Laotse

  • Moin,

    witzig ist dann nur, dass das im Montana 600 jahrelang mit der Custom 0.bmp funktioniert hat (den Namen hat ja auch BaseCamp verwendet und entsprechend in der GPX-Datei hinterlegt für das Symbol mit dem Dateinamen 000.bmp) - in Deinem Zitat tauchen auch widersprüchliche Angaben auf - "Name the BaseCamp symbols 001.bmp," - und eine Zeile tiefer dann "Only symbol names from 000.bmp..." - vielleicht hat sich da mal was geändert bei Garmin, sprich früher mal war die 0 als Start korrekt (typisch Programmierer und Arrays), jetzt funktioniert es damit nicht mehr (weil's dem Anwender oder wohl eher dem Marketing unlogisch schien).


    "Custom 10" hatte ich oben auch ohne führende 0 geschrieben, die 010 bezog sich auf das Pendant dazu, welches in BaseCamp genutzt wird. :)


    Viele Grüße

    Olaf