Datenbank bzw. Sammelablagen Problem

  • Hallo zusammen,


    leider habe ich es geschafft, mir mein super funktionierendes QMapShack zu zerstören. Ich hatte versucht, nicht mehr benötigte Daten aus der Datenbank zu löschen. Was ich dabei falsch gemacht habe, weiß ich nicht. Jetzt startet das Programm mit einer Fehlermeldung

    Mit Sammelablagen habe ich noch nicht gearbeitet, wenigstens nicht wissentlich. Order habe ich natürlich auch keine gelöscht.

    Im Hintergrund steht noch, dass die Karte geladen werde was aber nicht der Fall ist. Beenden kann ich das Ganze nur noch über den Taskmanager.

    Deinstallieren und die neueste Version installieren bringt leider keine Hilfe.


    Bin für jeden Tip dankbar

    Gruß

    Thomas

  • Wenn Du mit Windows arbeitest, dann finde die Datei


    c:\Users\your_user_name\.config\QLandkarte\workspace.db


    und benenne diese um, z.B. nach


    c:\Users\your_user_name\.config\QLandkarte\workspace.db.saved.


    Danach starte QMS neu. Vielleicht hilft das schon, QMS wiederzubeleben.


    Gruß

    Wolfgang

  • Also wenn Du noch nie was mit der Sammelablage gemacht hast, dann tippe ich eher auf eine komplett verkorkste Konfiguration. Die kann man löschen. Da du uns aber leider nicht das Betriebssystem verrätst, höre ich hier auf zu raten.

  • Erst mal Danke für die schnellen Antworten.

    Betriebssystem ist Windows 10.

    Es hat ja eigentlich alles prima funktioniert, ich wollte primär nicht benötigte Daten löschen. Alles direkt in QMS.

    Der Tip mit der workspace.db hat leider nicht funktioniert


    Gruß

    Thomas

  • Dann nächster Versuch mit nach wie vor weggeschobener workspace.db: QMS starten mit


    qmapshack -f -c blabla.ini


    aus dem Verzeichnis, wo qmapshack.exe liegt und wo es keine Datei blabla.ini gibt. Dann wird keine Konfiguration gelesen, da Konfigurationsdatei leer ist.


    Es wird außerdem ein Logfile geschrieben:


    %temp%\org.qlandkarte.QMapShack.log


    s. Wiki-Seite DocCmdOptions.

    Einmal editiert, zuletzt von wthaemelt ()

  • Unter Windows speicher QMapShack alle Einstellungen in der Registry ab.


    Du kannst jetzt in der Registry Nach QMapShack suchen und alles löschen. Dann sind alle Einstellungen weg und Du kannst frisch anfangen. Das sollte immer gehen.


    Oder Du ein wenig chirurgischer vor und löscht nur einen Teil. Die Einsetllungen sind in einem Baum abgespeichert. Dort gibt es einen Zweig `Database/Summary/`. Wenn Du nur den löschst sollte der Zustand der Sammelablagen zurückgesetzt werden. Jungfräulich sieht der so aus:


  • Zwar bin ich kein Mediziner, aber die OP an der Registry ist gelungen. Der Patient lebt und zeigt freudig wieder Karten an.

    Im Summary Ordner war ein Eintrag. Den habe ich gelöscht.


    Ganz herzlichen Dank an Kiozen!

    Danke natürlich auch an wthaemelt


    Gruß

    Thomas

  • Hallo zusammen,


    ich hatte auch ein Problem mit QMS 1.15.0 unter Windows 10, wobei mein Workspace nicht gespeichert wurde.

    Nach umbennen der workspace.db file wie hier oben beschrieben hat es jedoch wieder funktioniert.

    Ich weis nicht ob dies oefters vorkommt bei Benutzer aber wollte es nur kurz melden.

    Vielleicht ist es ein Idee um dieser Trick im Wiki zu beschreiben?

    Garming Oregeon 650, Garmin Edge Explorer, Fenix 6X Pro