Garmin Basecamp 4.6.2 (Keine Rückmeldung)

  • Lenovo Ideapad 320, Win 10 Vers. 1909, MS-Office 2010, AllData.gdb = 102 MB auf OneDrive, (Zumo 590)


    Hallo Newsgroupleser,


    seit 2 Tagen habe ich folgende Situation:


    Immer wenn ich in Basecamp Einstellungen vornehme, oder Basecamp beende kommt die „Eieruhr“, d. h. auch weder über das „Kreuz“ noch über den Taskmanager kann ich Basecamp beenden. Auch werden die gewünschten Veränderungen nicht übernommen. Nur über die Eingabeaufforderung „shutdown -s -f -t 00“ lässt sich Basecamp beenden. Nach einem Laptop-Neustart kann ich Basecamp wieder starten und auch meine Routen bearbeiten. Aber die vorher beschriebene Situation bleibt die gleiche. Alle anderen Programme auf dem Laptop lassen sich ordnungsgemäß starten und beenden.


    Was habe ich bisher unternommen:

    -       Basecamp 4.6.2, wie von Garmin empfohlen, über Windows-Systemsteuerung deinstalliert, danach Laptop neu gestartet und über das „Reset Windows Update Tool“ die Registry geprüft und bereinigt, danach noch mit CCleaner. Anschließend nach Neustart Basecamp 4.6.2 wieder installiert. Danach trat sofort das gleiche Verhalten auf.

    -       Das gleiche Prozedere habe ich danach mit Basecamp 4.7.1 gemacht. Das gleiche Resultat.

    -       Update von Win 10 Vers. 1903 auf Vers. 1909

    -       Eine 9 Tage alte Datensicherung in Basecamp 4.6.2 eingespielt. Die eingespielten Daten werden auch übernommen, aber der sonst vorgenommene automatische Neustart von Basecamp erfolgt nicht.


    So langsam gehen mir die Ideen aus, außer dass ich den Speicherort der Basecamp-DB von OneDrive auf „Standard“ umstelle, welches aber über die Basecamp-Einstellungen aus den o. a. Gründen so nicht zu realisieren lässt oder Neuinstallation von Windows.


    Wer hat noch eine Idee bzw. kann helfen?


    --

    Mit den besten Grüßen aus der Eifel

    Dieter

  • Hi, hast Du die Datei bei OneDrive mit "ImmerbehaltenaufdemPC" markiert ? Nun dann funkioniert es.

    Gruß Frank
    im Besitz:OR 700, Gps64s+66s, SATMAP Active20,
    Historie: OR 600 Reserve ,Aventura 2

  • Falls Du gar keine Vermutung hast, kannst in der Ereignisanzeige/ Windowsprotokolle mal blätteren, ob da was Auffälliges drin steht. Man kommt dort hin ,in dem man z.B. bei W10 in der Suchleiste Ereignis eintippt.


    Üblicherweise speichert BC beim Beenden alles in einer Datenbank. Könnte mir vorstellen, das BC wegen falschen Einstellungen dort nicht schreiben darf.

  • ich äußerte die Vermutung, dass BC wegen falscher Zugriffsrechte nicht in die Datenbank schreiben kann, also vom System daran gehindert wird. Das hat nichts damit zu tun, dass Du eine neue leere Datenbank angelegt hast. Du must den Ordner der Datenbank finden und dort mit dem Explorer -->Eigenschaften--> Sicherheit

    usw. prüfen, wer dort schreiben darf.

  • Du arbeitest mit der Datenbank auf OneDrive? Was passiert denn, wenn Du die "normale" und auf dem PC gespeicherte Standard-Datenbank benutzt? Funktioniert BaseCamp dann?
    Schon mal probiert lokal und somit auf dem Rechner eine neue Datenbank anzulegen? Funktioniert die wuschgemäss?

  • Hallo,


    erst einmal vielen Dank für Eure Antworten. Leider haben sie nicht zum Erfolg geführt.


    morgen1 :

    Alle Benutzer, inkl. "Jeder" haben Vollzugriff auf den Ordner.


    Sette :

    Ja.


    hans.j :

    Genau dies funktioniert auf Grund des Verhaltens von Basecamp nicht mehr. Auch nach Deinstallation und Neuinstallation von Basecamp kann ich den Speicherort nicht verändern. Habe dies auch in der Registry versucht. Kann dort zwar den Speicherort verändern, aber beim nächsten Start von Basecamp ist der Speicherort von "OneDrive" wieder eingetragen.


    --

    VG Dieter

  • Die Einstellungen und die verwendete Datenbank steht in einer eigenen Datei:


    "C:\Users\"YOUR USER NAME"\AppData\Local\GARMIN_Corp\BaseCamp.exe_Url_urbejbdz42c555ix3xqbitecusqt0tuj\4.5.2.1\user.config"


    Hab den Pfad vom EN-Garmin Forum kopiert.

    Der Fehler dort war ein anderer, BC startete nicht ohne die Datei vorher zu löschen.


    Wenn BC beendet wird, mit Änderungen in der Konfiguration, muss diese Datei geschrieben werden.

    Möglicherweise liegt das Problem bei dieser Datei.

  • Ich hatte letzthin nur Probleme mit BaseCamp, dem Zumo, Win10.....
    Nun habe ich den Vorteil, dass ich BaseCamp auf Windows in einer virtuellen Umgebung auf meinen Macs laufen lasse. Das heisst, Windows ist für mich nur "die Krücke für BaseCamp".


    Geholfen hat bei mir, dass ich einen neuen User angelegt habe und, nachdem dort auf Anhieb alles einwandfrei funktioniert hat, den alten User löschen konnte. War ja nix ausser BaseCamp drauf und meine BaseCamp-Datenbanken hatte ich via DropBox gesichert.

    Wäre das mal ein Versuch Wert? Neuen User anlegen und dort BaseCamp mal ausprobieren? Dann weisst Du immerhin, ob der Hund im System oder beim aktuellen User zu suchen ist.


    ToiToiToi, und leider (zum Glück) kenne ich mich mit Windows nicht aus. Viel mehr als zu dem Versuch raten kann ich leider nicht.

  • Hallo,


    erst einmal vielen Dank an alle, die sich mit meiner Situation beschäftigen.



    morgen1 :

    CloudEnabled hat den Wert 00.


    Slow Foot :

    Habe die Datei gelöscht. Danach Basecamp gestartet, neue user.config wurde angelegt, aber Bascamp wurde auf dem Bildschirm nicht abgebildet und nach nochmaligen starten von BC erhielt ich die Meldung BC sei schon gestartet. Habe die ursprüngliche user.config als txt-Datei angefügt.


    hans.j :

    Neuer User hat leider nicht geholfen.


    --

    VG Dieter

  • Schade. Als Mac-User würde ich jetzt sagen, dass der Fehler im System und nicht in den Nutzerdaten liegen müsste. Wird bei Windows wohl ähnlich sein.

    Womit ich mit meinem Latein definitiv am Ende bin / wäre und mal ein Wochenende zum platt machen und neu installieren opfern würde. Holzhammermethode, ich weiss.

    Viel Glück beim suchen des Fehlers.

  • in der user.config befindet sich bei mir der nachstehende Eintrag:

    <setting name="CurrentDatabaseName" serializeAs="String">

    <value />

    </setting>


    In Deiner user.config steht an dieser Stelle:

    <setting name="CurrentDatabaseName" serializeAs="String">

    <value>OneDrive</value>

    </setting>


    Wäre also einen Versuch wert, diesen Eintrag manuell zu ändern, um den Ort der Bascecamp-Datenbank auf das Standardverzeichnis zu bringen.

    Also <value>OneDrive</value> durch <value /> ersetzen. Hinter value befindet sich ein Leerzeichen.

    Dabei die user.config im Pfad der aktuellen Version ändern !

    www.clickpedal.de Gerätehistorie: GPS12, eTrex Summit, 60CS, 60CSx, Oregon300, 62s, eTrex30, WinTec WBT-202, Oregon650, Oregon700. Aktuell: GPSMAP66S SW: BaseCamp aktuelle Version, GPS-Einsatz vorw. bei MTB-Touren. Nach ZUMO340 für die GS nun Kyocera Duraforce Pro mit LocusMap, Nüvi 3597LMT für PKW, LOCUSMap auf Android

  • Hallo,


    hans.j :

    So wie es aussieht liegt eine Neuinstallation von Win 10 in nicht mehr so weiter Ferne.


    @trailsufer:

    Habe mit dem Programm "KaiEitor" die user.conf angepasst. Leider wird dann BaseCamp nicht mehr auf dem Bildschirm angezeigt und das System behauptet bei einem weiteren Start von BC, BC sei schon gestartet und es tut sich dann weiterhin gar nichts. Sobald die modifizierte user.conf durch die "Alte" ersetzt wird, wird zumindest BC gestartet.


    --

    VG Dieter

  • Die Wahrscheinlichkeit, dass es an W10 liegt, ist gering. Ich würde eher mal probieren, was passiert, wenn Du die user.config löschst oder den Inhalt komplett löschst. Bei mir ist die user.config an der bewußten Stelle identisch mit der von trailsurfer. Zum Ändern sollte man den windowseigenen Editor verwenden, damit sichergestellt ist, dass keine Formatierungsinfos rein kommen. Ich wundere mich selbst, das die nicht den xml-Konventionen entsprechende user.config überhaupz akzeptiert wird. Denn formal xml-konform wäre es nur so: <value> hier der Wert </value>. Ich würde auch mal testen, was passiert, wenn man zwischen die value tags den Pfad zur Datenbank schreibt

  • Schade das es nicht geholfen hat.


    Änderungen an der user.config sind eher nicht sinnvoll. Vieles versteckt sich dort in Binären Werten.

    Die Pfade zur Datenbank sind zBsp. hier gespeichert:

    Zitat

    name="UserDatabaseNames" serializeAs="Binary"


    Wenn ich das alles richtig durchblicke funktioniert alles am Laptop - außer das schließen von BC.

    Würden Datenbanken/Pfade defekt sein oder nicht stimmen würde BC nicht starten und man könnte die Daten nicht bearbeiten, wie im Eingangspost beschrieben.


    Es beginnt ja mit "seit 2 Tagen....."

    Was ist denn hier passiert?

    Wurden externe Daten importiert?

    War das Zumo angeschlossen und es ist noch eine Übertragung darauf offen?


    Diese Liste kann man wohl unendlich fortsetzen - ich würde aber auch darüber nochmal nachdenken.


    Ich bin kein Freund der Neuinstallation des ganzen Systems - außer es gibt weitere gute Gründe dafür.


    Wenn ich das richtig sehe hat eine Neuinstallation von BC soweit funktioniert aber ohne Auswirkung.

    Ich würde eine Neuinstallation von 4.6.2 nochmals durchführen, aber vorher die bestehende user.config entfernen/umbenennen !!

    Damit sollte die leere Standard Datenbank lokal auf der SSD erstellt werden. Wenn man damit arbeiten kann - hinzufügen/ändern/konfigurieren - und BC sich richtig verhält würde ich erst die Daten, wie im Eingangspost beschrieben, in die Standard Datenbak importieren.

    Sollte das alles funktionieren dann erst das Zumo anschließen.


    Ansonsten ist es aus der Ferne schwer das zu analysieren.

    Viel Erfolg!