Zurück   NaviBoard GPS Forum > Karten und Software > Digitale Kartenwerke > Eigene Vektorkarten erstellen oder Anpassen
Hinweise

Antwort
 
Themen-Optionen Thema durchsuchen Ansicht
  #1  
Alt 07.12.2014, 14:14
morgen1 morgen1 ist offline
NaviBoard Mitglied
 
Registriert seit: 23.12.2005
Beiträge: 2.848
mkgmap und _mdr.img, Fehler beim Kachelexport

Hallo, ich erzeuge mit mkgmap-r3336 meine OSM-Karten. In der template.args gebe ich -index und -code-page=1252 mit an und mkgmap erzeugt brav die _mdr.img und mdx.img. In Mapsource ist dann auch die globale Suche verfügbar und funktioniert. Problem :Es gibt einige Maptiles in Spanien und Nordafrika, die Probleme verursachen. Wenn diese Tiles in Mapsource ausgewählt werden --> senden an GPS, dann crasht Mapsource beim Erzeugen des MDR-Indexes. Die Fehlermeldung ist cryptisch, deutet aber auf ADDR- hin. Kennt jemamd das Problem ? bzw. klappt das senden der Maptiles bei euch ohne Crash ? Wenn ich die mdr nicht mit einbinde, dann klappt das Senden der Tiles. Die Problemkacheln sind typischerweise um Gibraltar herum und Ceuta & Mellila in Afrika. Das gesamte restliche Europa bereitet keine Probleme
Mir ist auf gefallen , dass Basecamp nicht alle Schriftzeichen darstellen kann, deshalb habe ich -code-page=1252 in Verdacht. Eventuell liegt es daran ? Aber welche codepage wäre denn für Spanien inclusive Nordafrika (wo vermutlich in der OSM arabische Schriftzeichen drin sind ?) besser geeeignet ?.
morgen1
Angehängte Grafiken
 
__________________
http://www.img2ms.de

Geändert von morgen1 (07.12.2014 um 14:17 Uhr)
Mit Zitat antworten
  #2  
Alt 07.12.2014, 17:27
Benutzerbild von Speichennippel
Speichennippel Speichennippel ist offline
NaviBoard Mitglied
 
Registriert seit: 29.01.2010
Beiträge: 1.191
Ich schreibe immer --latin1
Allerdings ohne zu wissen, weshalb oder was das ganz genau macht.
Vielleicht klappt es damit?
Mit Zitat antworten
  #3  
Alt 07.12.2014, 20:47
Benutzerbild von popej
popej popej ist offline
NaviBoard Mitglied
 
Registriert seit: 28.01.2008
Beiträge: 260
Zitat:
Zitat von morgen1 Beitrag anzeigen
Mir ist auf gefallen , dass Basecamp nicht alle Schriftzeichen darstellen kann, deshalb habe ich -code-page=1252 in Verdacht. Eventuell liegt es daran ? Aber welche codepage wäre denn für Spanien inclusive Nordafrika (wo vermutlich in der OSM arabische Schriftzeichen drin sind ?) besser geeeignet ?.
Besser wäre Unicode zu verwenden, aber dann einige Garmin-Geräte werden nicht die Karte akzeptieren. Für 1252 versuche Option wie:
--name-tag-list=int_name,name
__________________
popej
Mit Zitat antworten
  #4  
Alt 08.12.2014, 07:10
morgen1 morgen1 ist offline
NaviBoard Mitglied
 
Registriert seit: 23.12.2005
Beiträge: 2.848
mdr Fehler mkgmap-Mapsource

@ Speichennippel: --latin1 ist identisch mit code-page=1252 . habe mir von Deiner Seite Dein Style angeschaut und die ganzen .bat. Alle Achtung, Du hast mächtig viel Zeit usw. investiert. Kennst Du schon
Code:
...\mkgmap.jar mdr_creation.txt ..\822*.img
mit textfile
Zitat:
family-id=??
product-id=..
familie-name=..
series-name=.. output-dir=..overview-mapname=..index
Der Code ist vereinfacht, aber Du weist schon, wie er vollständig sein müßte. Nur als Anregung auf Deine ältere Frage diesbezüglich im Bord.
@ popej:
ja , das werde ich versuchen. Ich muß im Style einen action-block { $name* $name:en...} erfinden. Der name= sollte at first 'en', second 'de' und nur, falls kein 'en' oder 'de' exist, 'Name' verwendet werden. Habe da gestern schon probiert, aber meine Syntax war nicht korrekt.mkgmap meldet Fehler im Style.

Danke für die Antworten morgen 1
__________________
http://www.img2ms.de

Geändert von morgen1 (08.12.2014 um 07:14 Uhr)
Mit Zitat antworten
  #5  
Alt 08.12.2014, 10:17
Benutzerbild von Speichennippel
Speichennippel Speichennippel ist offline
NaviBoard Mitglied
 
Registriert seit: 29.01.2010
Beiträge: 1.191
Oh danke. Steh jetzt aber auf dem Schlauch, auf welche Frage sich das bezieht.
Mit Zitat antworten
  #6  
Alt 08.12.2014, 11:05
Benutzerbild von popej
popej popej ist offline
NaviBoard Mitglied
 
Registriert seit: 28.01.2008
Beiträge: 260
Zitat:
Zitat von morgen1 Beitrag anzeigen
Ich muß im Style einen action-block { $name* $name:en...} erfinden. Der name= sollte at first 'en', second 'de' und nur, falls kein 'en' oder 'de' exist, 'Name' verwendet werden.
"name-tag-list" ist eine Befehlszeilenoption für mkgmap. Es macht automatisch die gleichen. Sieh Beschreibung im Handbuch.
__________________
popej
Mit Zitat antworten
  #7  
Alt 08.12.2014, 11:55
morgen1 morgen1 ist offline
NaviBoard Mitglied
 
Registriert seit: 23.12.2005
Beiträge: 2.848
Zitat:
Zitat von Speichennippel Beitrag anzeigen
Oh danke. Steh jetzt aber auf dem Schlauch, auf welche Frage sich das bezieht.
auf Deine Frage vom 9.Mai 2014. http://www.naviboard.de/vb/showthread.php?t=56884 .Die blieb unbeantwortet. Und an Hand Deiner .bat sah ich, dass Du immer noch die umständliche Methode anwendest, also diesen undokumentierten Code nicht kennst. :
__________________
http://www.img2ms.de
Mit Zitat antworten
  #9  
Alt 08.12.2014, 16:19
morgen1 morgen1 ist offline
NaviBoard Mitglied
 
Registriert seit: 23.12.2005
Beiträge: 2.848
mdr Error in Mapsource

Dank an popej. mit dem name-tag-list=... konnte ich die Fragezeichen in den arabischen Städtenamen eliminieren. ..leider stürzt Mapsource beim Export gewisser spanischer Kacheln immer noch ab mit Fehler
Code:
MDR_TRIM_ADDR.CXX-347-6.16.3
Also liegt es nicht an eventuell unlesbaren Schriftzeichen.
__________________
http://www.img2ms.de
Mit Zitat antworten
Antwort

Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Fehler beim Registrieren der Karte wernerE CompeGPS Karten 9 13.02.2012 15:57
Fehler beim einschalten? mike58 StreetPilot 3 06.08.2008 15:27
Fehler beim convertieren von .mp zu .img K4nt3 Eigene Vektorkarten erstellen oder Anpassen 7 05.08.2008 17:38
Fehler beim Laden von OVL Dateien maschu Fugawi und TTQV 6 23.12.2006 18:10
Fehler beim Übertragen Peter300 GPSMap 60xx und 76xx Serie 2 14.04.2006 15:59


Alle Zeitangaben in WEZ +1. Es ist jetzt 17:56 Uhr.


Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS